Eggs Unlimited (release branch 6)
Last updated: Mon Oct 19 00:15:03 2026
A library of extensions for the CHICKEN Scheme system.
Installation
Just enter
chicken-install EXTENSIONNAME
This will download anything needed to compile and install the library. If your extension repository is placed at a location for which you don't have write permissions, then run chicken-install with the -sudo option or run it as root (not recommended).
You can obtain the repository location by running
csi -R chicken.platform -p "(repository-path)"
If you only want to download the extension source code, pass the -retrieve option to chicken-install:
chicken-install -retrieve EXTENSIONNAME
For more information, enter
chicken-install -help
List of available eggs
Categories
- Language extensions
- Graphics
- Debugging tools
- Logic programming
- Networking
- Input/Output
- Databases
- OS interface
- Interfacing to other languages
- Web programming
- XML processing
- Documentation tools
- Egg tools
- Mathematical libraries
- Object-oriented programming
- Algorithms and data-structures
- Data formats and parsing
- Tools
- Sound
- Unit-testing
- Cryptography
- User interface toolkits
- Code generation
- Macros and meta-syntax
- Miscellaneous
- Concurrency and parallelism
- Not categorized
- Unsupported or redundant
Language extensions
| Name | Description | License | Author | Maintainer | Version |
|---|---|---|---|---|---|
| begin-syntax | Convenience macro for inline syntax expansion | BSD | Evan Hanson | 0.2.1 | |
| brev-separate | Hodge podge of macros and combinators | BSD 1-clause | Idiomdrottning | 1.100 | |
| char-set-literals | A reader extension providing Gauche style literals for SRFI-14 char-sets | BSD | Moritz Heidkamp | The CHICKEN Team | 0.5 |
| chibi-config | Chibi Scheme's config library | BSD | Alex Shinn | Diego A. Mundo | 0.1.1 |
| chibi-generic | Chibi Scheme's simple generic function interface | BSD | Alex Shinn | Diego A. Mundo | 0.1.3 |
| clojurian | Syntax and utility functions inspired by Clojure | BSD | Moritz Heidkamp | 4 | |
| datatype | A facility for creating and deconstructing variant records (from EOPL) | BSD | felix winkelmann | 1.7 | |
| fast-generic | fast-generic functions | BSD | felix winkelmann | 0.7 | |
| foreigners | Foreign helper macros | BSD | Jim Ursetto | 1.6 | |
| hascheme | Implictly Lazy Scheme embedded into Scheme | BSD 0-clause | Peter McGoron | 0.3.0 | |
| make | The PLT 'make' macro | LGPL-2.0+ | PLT, adapted to CHICKEN by Felix Winkelmann | 1.10 | |
| matchable | Hygienic MATCH replacement | Public Domain | Alex Shinn | 1.2 | |
| matchertext | Reader extension for embedding matchertext as string literals. | GPLv3 | Hernán Ibarra Mejia | 2.0 | |
| miscmacros | Various helper macros | BSD | felix winkelmann | 1.3 | |
| module-declarations | Module declarations | BSD | Evan Hanson | 0.3.1 | |
| moremacros | More miscellaneous macros | BSD | Kon Lovett | 3.1.2 | |
| prefixes | prefixing in er-macro-transformers made easy | BSD | Juergen Lorenz | 2.0 | |
| record-variants | Optimized record access | BSD | Jim Ursetto | 1.2 | |
| regex-case | Provides an easy to use <code>case</code> construct for regular expression matching | BSD | felix | 1.3 | |
| srfi-105 | SRFI-105 - curly infix expressions | MIT | David A. Wheeler | Diego A. Mundo | 0.1.8 |
| srfi-158 | SRFI 158: Generators and Accumulators | MIT | Shiro Kawa, John Cowan, Thomas Gilray | Vasilij Schneidermann | 1.0 |
| srfi-160 | SRFI 160: Homogeneous numeric vector libraries | MIT | John Cowan, Shiro Kawai | Diego A. Mundo | 0.6.0 |
| srfi-197 | SRFI-197: Pipeline Operators | MIT | Adam Nelson | Diego A. Mundo | 0.2.1 |
| srfi-232 | SRFI 232: Flexible curried procedures | MIT | Wolfgang Corcoran-Mathe | Wolfgang Corcoran-Mathe | 0.2 |
| srfi-48 | SRFI-48: Intermediate Format Strings | MIT | Ken Dickey | Wolfgang Corcoran-Mathe | 1.1.0 |
| srfi-5 | SRFI-5: A compatible let form with signatures and rest arguments | MIT | Andy Gaynor | Wolfgang Corcoran-Mathe | 0.4.1 |
| typeclass | Type classes | MIT | Andre van Tonder | Ivan Raikov | 1.6 |
| varg | A template for defining dynamic arguments procedure | MIT | riku-ri | riku-ri | 1.1.2 |
Graphics
| Name | Description | License | Author | Maintainer | Version |
|---|---|---|---|---|---|
| cairo | Chicken bindings for Cairo, a vector graphics library | LGPL-2.1 | Michael Bridgen and Tony Garnock-Jones | Ivan Raikov | 1.3 |
| color | The SLIB color library | BSD | Aubrey Jaffer | Erik Falor | 1.2 |
| ezxdisp | A simple 2D and 3D graphics library for X11 | LGPL-2 | n-sibata and Morihiko Tamai | Ivan Raikov | 3.2 |
| ggplot | A declarative plotting system based on Grammar of Graphics. | GPL-3 | Ivan Raikov | 1.4 | |
| leptonic | Bindings for image-processing library 'leptonica' | BSD-2 | Jules Altfas | 0.2.4 | |
| A library for PDF generation. | BSD | Marc Battyani and Bruce Butterfield | Ivan Raikov | 2.2 | |
| pdf-truetype | TrueType font embedding for the pdf egg. | BSD | Ivan Raikov | 1.0 | |
| raylib | Bindings for raylib: A simple and easy-to-use library to enjoy videogames programming | MIT | Meowster | 1.3.0 | |
| s9fes-char-graphics | Scheme 9 from Empty Space Char Graphics | Public Domain | Kon Lovett | 1.22.0 | |
| s9fes-char-graphics-shapes | Scheme 9 from Empty Space Char Graphics Shapes | Public Domain | Kon Lovett | 1.7.1 | |
| slib-charplot | The SLIB character plotting library | Artistic | Aubrey Jaffer | Kon Lovett | 1.4.4 |
| x11-colors | named standard colors as available in X11 | BSD | felix winkelmann | Erik Falor | 1.2.1 |
Debugging tools
| Name | Description | License | Author | Maintainer | Version |
|---|---|---|---|---|---|
| tcprepl | Simple networked REPL over TCP | BSD | Kristian Lein-Mathisen | 6.1.0 |
Logic programming
| Name | Description | License | Author | Maintainer | Version |
|---|---|---|---|---|---|
| amb | The non-deterministic backtracking ambivalence operator | BSD | thomas chust | Kon Lovett | 3.0.11 |
| mini-kanren | Packages the canonical miniKanren implementation for CHICKEN Scheme. | MIT | William Byrd, Dan Friedman, Oleg Kiselyov | Jeremy Steward | 1.3.2 |
| tiny-prolog | Tiny PROLOG interpreter. | BSD | Nils M Holm | Ivan Raikov | 2.2 |
Networking
| Name | Description | License | Author | Maintainer | Version |
|---|---|---|---|---|---|
| address-info | Network address information access | BSD | Thomas Chust | 1.0.6 | |
| fcp | Very basic interface to freenet FCP | BSD | Matt Welland | v1.2 | |
| http-client | High-level HTTP client library | BSD | Peter Bex | 2.0.1 | |
| json-rpc | A JSON RPC library for R7RS scheme. | MIT | Ricardo G. Herdt | 0.6.5.2 | |
| memcached | Client interface to the Memcached protocol. | BSD | Ivan Raikov and Seth Alves | 1.6 | |
| mpi | Message-passing Interface (MPI) | GPL-3 | Ivan Raikov | 2.7 | |
| openssl | Bindings to the OpenSSL SSL/TLS library | BSD | Thomas Chust | Vasilij Schneidermann | 2.2.8 |
| sendfile | Sending a file over the network | BSD | David Krentzlin | 3.0 | |
| smtp | Parser combinators and state machine for Simple Mail Transfer Protocol (RFC 5321). | GPL-3 | Ivan Raikov | 5.3 |
Input/Output
| Name | Description | License | Author | Maintainer | Version |
|---|---|---|---|---|---|
| breadline | Bindings to readline | GPL-3 | Vasilij Schneidermann | 1.0.3 | |
| chibi-term | Chibi Scheme's term library | BSD | Alex Shinn | Diego A. Mundo | 0.1.0 |
| endian-port | An I/O port that supports different endian formats. | GPL-3 | Ivan Raikov, partially reimplemented by Shawn Rutledge | 5.0 | |
| fmt | Combinator Formatting | BSD | Alex Shinn | 0.8.14 | |
| format | Common-Lisp style formatted output | Public Domain | Dirk Lutzebeck | Felix Winkelmann, Kon Lovett | 3.2.4 |
| inotify | Bindings to inotify | MIT | Vasilij Schneidermann | 2.0 | |
| linenoise | A minimal, zero-config, BSD licensed, readline replacement. | BSD | Salvatore Sanfilippo | Christian Kellermann | 1.1 |
| simple-logger | A very simple logger | BSD | Mario Domenech Goulart | 1.0.1 | |
| srfi-38 | SRFI 38: External representation for data with shared structure | Public Domain | Alex Shinn | Wolfgang Corcoran-Mathe | 0.10 |
| stty | stty-style interface to termios | BSD | Alex Shinn | Erik Falor | 1.0 |
| wl-pprint | Wadler/Leijen-style pretty-printing combinator library | MIT | Ivan Raikov | 1.0 |
Databases
| Name | Description | License | Author | Maintainer | Version |
|---|---|---|---|---|---|
| leveldb | Bindings to Google's LevelDB Key-Value Store | BSD | Kristian Lein-Mathisen | 6.1.2 | |
| postgresql | Bindings for PostgreSQL's C-api | BSD | Johannes Groedem | Peter Bex | 5.0.1 |
| redis | A Redis client library for Chicken Scheme | BSD | Daniel Ziltener | 0.9 | |
| sql-null | A convenience extension for representing SQL NULL values | Public Domain | Ivan Shmakov | 2.2 |
OS interface
| Name | Description | License | Author | Maintainer | Version |
|---|---|---|---|---|---|
| dot-locking | advisory locking mechanism based on standard file operations | BSD | Olin Shivers | felix | 0.5 |
| locale | Provides locale operations | BSD | Kon Lovett | 0.10.1 | |
| posix-groups | Access POSIX group information | BSD | The CHICKEN Team | 0.3 | |
| posix-mq | POSIX message queues API | BSD | Ivan Raikov | 1.3 | |
| posix-shm | POSIX shared memory API | BSD | Ivan Raikov | 1.6 | |
| poule | Manage pools of worker processes | BSD | Pietro Cerutti | 0.1.3 | |
| scsh-process | A reimplementation for CHICKEN of SCSH's process notation. | BSD | Peter Bex | 1.7.2 | |
| xdg-basedir | Implementation of the XDG Base Directory Specification | BSD | Mario Domenech Goulart | 1.0.1 |
Interfacing to other languages
| Name | Description | License | Author | Maintainer | Version |
|---|---|---|---|---|---|
| bind | Automatically generate bindings from C/C++ declarations | public domain | felix winkelmann | 1.4 | |
| dollar | FFI convenience macro | BSD | felix winkelmann and kon lovett | 3.2.0 | |
| lazy-ffi | A foreign function interface for lazy programmers | BSD | felix | 1.8.7 |
Web programming
| Name | Description | License | Author | Maintainer | Version |
|---|---|---|---|---|---|
| awful | awful provides an application and an extension to ease the development of web-based applications. | BSD | Mario Domenech Goulart | 1.0.5 | |
| awful-main | Turn awful web applications into static executables | BSD | Pietro Cerutti | 0.3.1 | |
| awful-sse | Server-Sent Events module for Awful | BSD | Arthur Maciel | 0.4 | |
| colorize | Colorize programming code as HTML | MIT | Brian Mastenbrook, converted to Scheme by Peter Bex | Peter Bex | 0.6 |
| fancypants | Automatic ASCII smart quotes and ligature handling for SXML | BSD | Peter Bex | 0.6 | |
| html-parser | A permissive, scalable HTML parser. | BSD | Alex Shinn | 0.5.0 | |
| http-session | Facilities for managing HTTP sessions | BSD | Mario Domenech Goulart | 2.12 | |
| intarweb | A more convenient HTTP library | BSD | Peter Bex | 3.0.1 | |
| pebble | Simple static site generator | AGPL-3.0-only | Diego A. Mundo | 1.2.0 | |
| qwiki | qwiki - the quick wiki | BSD | Peter Bex | 2.4.2 | |
| spiffy | A small but powerful web server | BSD | Felix Winkelmann | Peter Bex | 6.5.2 |
| spiffy-cookies | Procedures for managing cookies | BSD | Mario Domenech Goulart | 1.3 | |
| spiffy-request-vars | Easy access to variables from HTTP requests | BSD | Mario Domenech Goulart | 0.20 | |
| spiffy-uri-match | uri-match integration for spiffy | BSD | Moritz Heidkamp | Vasilij Schneidermann | 1.1 |
| uri-common | Parser for common URI schemes | BSD | Peter Bex | 3.0 | |
| uri-generic | URI generic syntax (RFC 3986) parsing and manipulation. | BSD | Ivan Raikov, Peter Bex, Seth Alves | 4.0 | |
| uri-match | A flexible URI matcher | BSD | Moritz Heidkamp | Vasilij Schneidermann | 1.0 |
XML processing
| Name | Description | License | Author | Maintainer | Version |
|---|---|---|---|---|---|
| doctype | Exports strings corresponding to standard XML (XHTML, HTML) doctypes | Public Domain | Jim Ursetto | 2.2 | |
| rss | A RSS parser | BSD | felix winkelmann | 1.8 | |
| ssax | Oleg Kiselyov's XML parser | Public Domain | Oleg Kiselyov, ported to CHICKEN by Kirill Lisovsky, packaged as an extension by felix | 5.1.2 | |
| sxml-serializer | Serialize SXML to XML and HTML | BSD | Dmitry Lizorkin | 0.6.1 | |
| sxml-transforms | The SXML transformations (to XML, SXML, and HTML) from the SSAX project at Sourceforge | Public Domain | Oleg Kiselyov | 1.5.0 | |
| sxpath | The sxpath bits of sxml-tools from the SSAX project at Sourceforge | Public Domain | Oleg Kiselyov, Kirill Lisovsky, Dmitry Lizorkin | 1.1 |
Documentation tools
| Name | Description | License | Author | Maintainer | Version |
|---|---|---|---|---|---|
| chalk | Syntax for in-source documentation | BSD | Diego A. Mundo | 1.0.2 | |
| chalk-bin | Generate in-source documentation | BSD | Diego A. Mundo | 1.0.3 | |
| chicken-doc | Explore Chicken documentation locally | BSD | Jim Ursetto | 0.7.1 | |
| chicken-doc-html | Generate HTML from (svn)wiki SXML | BSD | Jim Ursetto | 0.4.1 | |
| manual-labor | Generate static HTML manual from wiki docs | BSD | Jim Ursetto | 0.4 | |
| svnwiki-sxml | Parse svnwiki to sxml | BSD | Jim Ursetto | 0.3.1 |
Egg tools
| Name | Description | License | Author | Maintainer | Version |
|---|---|---|---|---|---|
| henrietta | Serve extensions over HTTP | BSD | felix winkelmann | 1.6 | |
| henrietta-cache | Fetch and cache extensions from various sources for Henrietta to consume | BSD | Peter Bex | 1.8 | |
| lay | Lay eggs efficiently | BSD | Pietro Cerutti | 0.4.0 | |
| pseudo-meta-egg-info | Provide automatically generated release-info and a pseudo-"meta"-file for eggs in svn | Public Domain | Peter Bex | 1.2 | |
| salmonella | A tool for testing eggs | BSD | Mario Domenech Goulart | 3.2.1 | |
| salmonella-diff | A tool to diff salmonella log files | BSD | Mario Domenech Goulart | 1.1.1 | |
| salmonella-html-report | A tool to generate HTML ouput out of salmonella log files | BSD | Mario Domenech Goulart | 1.7.2 |
Mathematical libraries
| Name | Description | License | Author | Maintainer | Version |
|---|---|---|---|---|---|
| blas | An interface to level 1, 2 and 3 BLAS routines | BSD | felix | Ivan Raikov | 5.2 |
| chibi-math | Chibi Scheme's math library | BSD | Alex Shinn | Diego A. Mundo | 0.1.0 |
| constructive-solid-geometry | Construct three dimensional solids | GPL-3 | Michal Herko | 0.1 | |
| fp-utils | fp utilities | BSD | Kon Lovett | 5.0.0 | |
| fx-utils | fx utilities | BSD | Kon Lovett | 5.0.0 | |
| math-utils | Miscellaneous math utilities | Public Domain | Kon Lovett | 1.19.0 | |
| mathh | ISO C math functions and constants | Public Domain | Kon Lovett and john cowan | 4.7.2 | |
| micro-stats | Easily create micro-stats | GPLv3 | David Krentzlin | Kon Lovett | 0.7.2 |
| nanograd | Minimalistic automatic differentiation framework. | LGPL-3 | Ivan Raikov | 3.2 | |
| nanograd-components | Model components for nanograd. | LGPL-3 | Ivan Raikov | 1.1 | |
| srfi-141 | SRFI 141: Integer division | BSD | Taylor Campbell, John Cowan | Wolfgang Corcoran-Mathe | 1.1.0 |
| srfi-143 | SRFI 143: Fixnums | MIT | John Cowan | Sergey Goldgaber | 1.1.0 |
| srfi-144 | SRFI 144: Flonums | MIT | John Cowan | Diego A. Mundo | 0.1.4 |
| srfi-278 | Supplemental Numerics (includes complex hyperbolic functions) | MIT | Peter McGoron | 1.0.0 | |
| statistics | Statistics library | GPL-3 | Peter Lane | Ivan Raikov | 0.15 |
| unitconv | Conversion of units of measurement | LGPL-3 | Ivan Raikov | 4.1 |
Object-oriented programming
| Name | Description | License | Author | Maintainer | Version |
|---|---|---|---|---|---|
| coops | A featureful object system | BSD | Dorai Sitaram and felix winkelmann | 1.6 | |
| coops-utils | coops utilities | BSD | Kon Lovett | 3.1.0 | |
| prometheus | The Prometheus Object System. | BSD | Daniel Ziltener | 1.0.1 | |
| yasos | A very simple OOP system | BSD | Kenneth Dickey | 1.15 |
Algorithms and data-structures
| Name | Description | License | Author | Maintainer | Version |
|---|---|---|---|---|---|
| array-morphisms | Structure-preserving transformations between arrays. | LGPL-3 | Ivan Raikov | 2.1 | |
| array-morphisms-blas | System-BLAS-based backend for array-morphisms. | LGPL-3 | Ivan Raikov | 1.0 | |
| array-morphisms-crunch | Crunch-based array-morphisms kernels for BLAS, activation, convolution and optimizer. | LGPL-3 | Ivan Raikov | 1.1 | |
| bitwise-utils | Bitwise utilities | Public Domain | Kon Lovett | 1.4.1 | |
| bloom-filter | Bloom Filter | BSD | Kon Lovett | 2.6.0 | |
| box | Boxing | BSD | Kon Lovett | 3.9.1 | |
| byte-sequence | Byte array utility procedures for byte sequences. | LGPL-3 | Ivan Raikov | 3.0 | |
| bytevector-utils | Bytevector Utilities | BSD | Kon Lovett | 1.0.1 | |
| cbor | Concise Binary Object Representation (RFC 8949) with typed arrays (RFC 8746) | MIT | Ivan Raikov | 1.0 | |
| chibi-diff | Chibi Scheme's diff library | BSD | Alex Shinn | Diego A. Mundo | 0.1.1 |
| chibi-edit-distance | Chibi Scheme's edit-distance library | BSD | Alex Shinn | Diego A. Mundo | 0.1.0 |
| cis | Compact integer sets. | LGPL-3 | Ivan Raikov | 1.5 | |
| coin-change | Greedy solver for the coin change problem | unlicense | siiky | 1.0.4 | |
| dataframe | Tabular data structure for data analysis | GPL-3 | Ivan Raikov | 1.0 | |
| defstruct | A more convenient form of define-record | BSD | Dorai Sitaram | 2.1 | |
| digraph | Directed graph in adjacency list format. | GPL-3 | Ivan Raikov | 2.1 | |
| disjoint-set | Disjoint set implementation based on Scheme vectors and their indexes | unlicense | siiky | 0.1.0 | |
| endian-sequence | Endian-specific procedures for converting byte sequences to numeric values and vectors. | GPL-3 | Ivan Raikov | 3.0 | |
| ftl | Interface based sequence library | LGPL-2.1 | Sergei Egorov, partially reimplemented by felix winkelmann | Felix Winkelmann | 0.91 |
| fusion-arrays | Fusion arrays. | GPL-3 | Ivan Raikov | 1.1 | |
| generalized-arrays | Provides generalized arrays, intervals, and storage classes for CHICKEN Scheme. | BSD-3 | Jeremy Steward | 2.3.0 | |
| graph-bfs | Breadth-first search in a graph. | GPL-3 | Ivan Raikov | 2.2 | |
| graph-cycles | Enumerate all simple cycles in a graph. | GPL-3 | Ivan Raikov | 2.1 | |
| graph-dfs | Depth-first search in a graph. | GPL-3 | Ivan Raikov | 2.1 | |
| graph-scc | Compute strongly-connected components (SCC) of a graph. | GPL-3 | Ivan Raikov | 2.1 | |
| hash-trie | hash-trie | MIT | Taylor R. Campbell | Kon Lovett | 1.2.0 |
| integer-map | SRFI 224 integer mappings | MIT | Wolfgang Corcoran-Mathe | Wolfgang Corcoran-Mathe | 1.1.0 |
| iset | Integer sets | BSD | Alex Shinn | 2.3.1 | |
| kd-tree | K-D tree spatial indexing structure. | GPL-3 | Ivan Raikov | 6.2 | |
| lazy-seq | Clojure-like lazy sequences | BSD | Moritz Heidkamp | 3 | |
| levenshtein | Levenshtein edit distance | BSD | Kon Lovett | 3.1.0 | |
| list-utils | list-utils | BSD | Kon Lovett | 3.4.0 | |
| llama | Inference with Llama2 model. | MIT | Ivan Raikov | 2.0 | |
| npdiff | Compute the longest common subsequence of two sequences | GPL-3 | Ivan Raikov | 3.1 | |
| object-evict | Evict data to unmanaged memory | BSD | The CHICKEN Team | 0.1.1 | |
| patch | Simple source patch utility | MIT | Tony Sidaway | Ivan Raikov | 1.16 |
| pserializer | Portable serializer with SRFI-4, hash-table and compression support | BSD | Shiro Kawai, Ivan Raikov | 1.0 | |
| quasiwalk | A tree map that respects quote, quasiquote, and unquote | BSD 1-clause | Idiomdrottning | 1.12 | |
| queues | A queue data structure | Public Domain | Andrew Wilcox, ported to CHICKEN by felix | 0.1 | |
| r6rs-bytevectors | An implementation of r6rs bytevectors | MIT | William D Clinger | Diego Mundo | 0.1.8 |
| random-mtzig | MT19937 random number generator with Marsaglia and Tang's Ziggurat algorithm to generate random numbers from a non-uniform distribution. | BSD | Ivan Raikov | 5.2 | |
| rb-tree | A sorted dictionary data structure based on red-black trees. | GPL-3 | Ivan Raikov | 6.3 | |
| record-vector | The dumb simple inplace data records without type tag. | BSD | Anton Idukov | 1.0.2 | |
| records | Procedural record-type interface | Public Domain | David Carlton, Aubrey Jaffer | 1.4 | |
| salt | Hybrid dynamical systems modeling. | GPL-3 | Ivan Raikov | 0.31 | |
| sequences | Generic sequence operators | BSD | felix winkelmann | 0.6.1 | |
| sequences-utils | (More) Generic sequence operators | BSD | Kon Lovett | 0.6.0 | |
| sexp-diff | S-Expression diff algorithm | LGPL | Michael Weber and Vincent St-Amour | Kon Lovett | 0.6.0 |
| slib-arraymap | The SLIB applicative routines for the arrays library | BSD | Aubrey Jaffer | Kon Lovett | 1.2.0 |
| slib-compat | CHICKEN SLIB compatibility library | Artistic | Kon Lovett | 1.1.1 | |
| slib-wt-tree | Weight-balanced trees | GPLv2 | Stephen Adams | Wolfgang Corcoran-Mathe | 0.2.0 |
| slset | Lists of symbols as sets | BSD | Peter Bex | 0.1 | |
| sparse-vectors | Arbitrarily large vectors | BSD | Richard Kelsey and Jonathan Rees | Felix Winkelmann | 1.2.0 |
| srfi-1 | SRFI-1 list library | BSD | Olin Shivers | The CHICKEN Team | 0.5.1 |
| srfi-113 | SRFI-113: Sets and Bags | BSD | John Cowan | Jeremy Steward | 2.0.0 |
| srfi-116 | SRFI-116: Immutable Lists. | BSD | John Cowan | Jeremy Steward | 2.0.0 |
| srfi-117 | SRFI-117: Mutable Queues | BSD | John Cowan | Jeremy Steward | 2.0.0 |
| srfi-123 | SRFI-123 - Generic accessor and modifier operations | MIT | Taylan Ulrich Bayırlı/Kammer | Diego A. Mundo | 0.3.0 |
| srfi-127 | SRFI-127: Lazy Sequences | BSD | John Cowan | Ivan Raikov | 1.5.1 |
| srfi-128 | SRFI-128: Comparators (reduced) | BSD | John Cowan | Jeremy Steward, Jörg F. Wittenberger | 1.0.1 |
| srfi-13 | SRFI-13 string library | BSD | Olin Shivers | The CHICKEN Team | 0.3.8 |
| srfi-132 | SRFI-132: Sort Libraries | BSD | John Cowan | Wolfgang Corcoran-Mathe | 1.1.0 |
| srfi-133 | SRFI-133: Vector Library (R7RS-compatible) | BSD | John Cowan, Taylor Campbell, Will Clinger | Jeremy Steward | 2.0.0 |
| srfi-134 | SRFI 134: Immutable deques | MIT | John Cowan, Kevin Wortman, Shiro Kawai, and Wolfgang Corcoran-Mathe | Wolfgang Corcoran-Mathe | 1.2.0 |
| srfi-137 | SRFI-137: Minimal Unique Types | MIT | John Cowan & Marc Nieper-Wißkirchen | Wolfgang Corcoran-Mathe | 0.3 |
| srfi-14 | SRFI-14 character-sets library | BSD | Olin Shivers | The CHICKEN Team | 0.2.5 |
| srfi-151 | SRFI 151: Bitwise Operations | MIT | Olin Shivers, Aubrey Jaffer, John Cowan | Sören Tempel | 1.0.3 |
| srfi-152 | String library (reduced) | MIT | John Cowan | Daniel Ziltener | 1.0 |
| srfi-162 | SRFI-162: Comparators sublibrary | BSD-2 | John Cowan | Jules Altfas | 0.1.1 |
| srfi-178 | SRFI 178: Bitvector library | MIT | John Cowan and Wolfgang Corcoran-Mathe | Wolfgang Corcoran-Mathe | 1.1.0 |
| srfi-179 | SRFI-179: Nonempty Intervals and Generalized Arrays (Updated) | MIT | Bradley Lucier | Diego A. Mundo | 0.3.1 |
| srfi-189 | SRFI 189: Maybe and Either | MIT | John Cowan and Wolfgang Corcoran-Mathe | Wolfgang Corcoran-Mathe | 1.1.0 |
| srfi-19 | Time Data Types and Procedures | BSD | Will Fitzgerald (for CHICKEN by Kon Lovett) | Kon Lovett | 5.1.2 |
| srfi-196 | SRFI-196: Range Objects | MIT | John Cowan & Wolfgang Corcoran-Mathe | Wolfgang Corcoran-Mathe | 1.1.1 |
| srfi-207 | SRFI-207: String-notated bytevectors | MIT | Daphne Preston-Kendal, John Cowan, & Wolfgang Corcoran-Mathe | Wolfgang Corcoran-Mathe | 2.1.0 |
| srfi-209 | SRFI 209: Enums and enum sets | MIT | John Cowan and Wolfgang Corcoran-Mathe | Wolfgang Corcoran-Mathe | 1.4.2 |
| srfi-259 | Tagged procedures with type safety (with SRFI-229 compatability) | MIT | Peter McGoron | 2.0.0 | |
| srfi-27 | Sources of Random Bits | BSD | Sebastian Egner, for CHICKEN by Kon Lovett and Sergey Goldgaber | Kon Lovett | 4.3.3 |
| srfi-271 | Random port libraries | BSD 0-clause | Peter McGoron | 1.0.0 | |
| srfi-41 | SRFI 41 (Streams) | BSD | Philip L. Bewig, for CHICKEN by Kon Lovett | Kon Lovett | 2.3.3 |
| srfi-42 | SRFI-42 (Eager comprehensions) | SRFI | Sebastian Egner | Ivan Raikov | 1.77 |
| srfi-63 | Homogeneous and heterogeneous arrays | Artistic | Aubrey Jaffer, ported to hygienic Chicken with test suite by Peter Danenberg | Kon Lovett | 1.0.1 |
| srfi-69 | SRFI-69 hash-table library | BSD | The CHICKEN Team | The CHICKEN Team | 0.5.3 |
| srfi-69-weak | SRFI-69/90 hash-table library (w/ weak references) | BSD | The CHICKEN Team and Kon Lovett | Kon Lovett | 2.3.3 |
| srfi-99 | SRFI-99 record types | BSD | Thomas Chust | 1.4.6 | |
| stack | Provides LIFO queue (stack) operations | BSD | Kon Lovett | 4.1.0 | |
| string-utils | String Utilities | BSD | Kon Lovett | 3.6.1 | |
| symbol-utils | Symbol Utilities | BSD | Kon Lovett | 3.0.0 | |
| tabular | Parsing and formatting of tabular text data such as comma- and delimiter-separated values (CSV and DSV). | GPL-3 | Ivan Raikov | 1.5 | |
| transducers | Transducers for working with foldable data types. | MIT | Jeremy Steward | 0.10.0 | |
| trie | A trie (prefix tree) implementation | BSD | Moritz Heidkamp | 3 | |
| vector-lib | Port of the SRFI-43 reference implementation | BSD | Taylor Campbell | The CHICKEN Team | 2.2 |
| vlist | An implementation of vlists, a functional list-like data structure. | LGPL-3 | Ludovic Courtès | Ivan Raikov | 1.2 |
Data formats and parsing
| Name | Description | License | Author | Maintainer | Version |
|---|---|---|---|---|---|
| abnf | Parser combinators for Augmented BNF grammars (RFC 4234). | GPL-3 | Ivan Raikov | 9.1 | |
| base64 | Encoding and decoding of base64 strings | BSD | James Bailey, Jim Ursetto | 1.1 | |
| cmark | A chicken wrapper for cmark with markdown to sxml capabilities | MIT | Harley Swick | Diego A. Mundo | 0.2.1 |
| comparse | Schemely parser combinators | BSD | Moritz Heidkamp | 5 | |
| csv-abnf | Parsing and formatting of comma-separated values (CSV). | GPL-3 | Ivan Raikov | 6.2 | |
| ersatz | A template engine inspired by Jinja2 and Jingoo. | LGPL-3 | Ivan Raikov | 1.31 | |
| filepath | Cross-platform file path manipulation. | BSD | Ivan Raikov | 1.8 | |
| icu | Chicken bindings to the ICU unicode library | Unicode | Diego A. Mundo | 0.3.4 | |
| input-parse | input-stream tokenizing and parsing routines. | Public Domain | Oleg Kiselyov. Ported to chicken by Shawn Wagner. | 1.2 | |
| internet-message | Parser combinators for Internet Message Format (RFC 5322). | GPL-3 | Ivan Raikov | 8.0 | |
| json | A JSON library | MIT | Tony Garnock-Jones | 1.7 | |
| json-abnf | Parser combinators for JavaScript Object Notation (JSON). | GPL-3 | Ivan Raikov | 8.0 | |
| lalr | An efficient LALR(1) parser generator | LGPL-3 | Dominique Boucher | Ivan Raikov | 2.5.4 |
| lexgen | Lexer combinators | GPL-3 | Ivan Raikov | 8.3 | |
| lowdown | A pure Chicken Markdown parser | BSD | Moritz Heidkamp | 4 | |
| msgpack | MessagePack implementation for CHICKEN | BSD | Hugo Arregui | Théo Cavignac | 2.0.0 |
| packrat | A packrat parsing library | MIT | Tony Garnock-Jones | felix winkelmann | 1.6 |
| rfc3339 | RFC3339 datetime parser | BSD | Jim Ursetto | 0.1.4 | |
| silex | An efficient and powerful lexer generator | BSD | Danny Dubé | 1.1 | |
| srfi-115 | SRFI 115: Scheme Regular Expressions | MIT | Alex Shinn | Wolfgang Corcoran-Mathe | 0.4.0 |
| srfi-180 | A JSON parser and printer that supports JSON bigger than memory. | BSD | Daniel Ziltener | 1.6.3 | |
| srfi-233 | SRFI 233: INI files | MIT | Lilianna Smólska, John Cowan, Arvydas Silanskas | Lilianna Smólska | 1.0.1 |
| utf8 | Unicode support shim | BSD | Felix Winkelmann | 3.7.0 |
Tools
| Name | Description | License | Author | Maintainer | Version |
|---|---|---|---|---|---|
| autocompile | Automatically compile Scheme scripts on demand | public domain | felix winkelmann | 1.1.1 | |
| chicken-update | Update installed eggs | public domain | Diego A. Mundo | 0.1.8 | |
| commands | Helpers for programs that dispatch commands | BSD | Mario Domenech Goulart | 1.0.2 | |
| csm | a build system | BSD | felix | 0.96 | |
| dotenv | A simple .env file loader | MIT | Masood Ahmed | v1.0.1 | |
| edward | An extensible implementation of the ed text editor as defined in POSIX.1-2008 | GPLv3 | Sören Tempel | 1.2.0 | |
| egg-tarballs | Creates tarballs for eggs in henrietta cache | BSD | Mario Domenech Goulart | 1.1.0 | |
| feathers | A simple debugger for CHICKEN | BSD | felix winkelmann | The CHICKEN team | 0.2 |
| henrietta-cache-git | A tool to convert and keep henrietta's cache in a git repository | BSD | Mario Domenech Goulart | 0.0.3 | |
| message-digest-utility | A message-digest utility | BSD | Kon Lovett | 0.1.2 | |
| svnwiki2html | A program to convert svnwiki syntax to HTML | BSD | Mario Domenech Goulart | 0.1.3 | |
| test-new-egg | A tool to test new eggs before they are added to the official CHICKEN repository | BSD | Mario Domenech Goulart | 1.0.5 | |
| tick | BSD | Mario Domenech Goulart | 0.0.1 | ||
| trace | tracing and breakpoints | public domain | felix winkelmann | 2.0 |
Sound
| Name | Description | License | Author | Maintainer | Version |
|---|---|---|---|---|---|
| espeak | Chicken bindings for espeak-ng's speak_lib.h | GPL-3.0 | Diego A. Mundo | 0.2.0 |
Unit-testing
| Name | Description | License | Author | Maintainer | Version |
|---|---|---|---|---|---|
| micro-benchmark | Easily create micro-benchmarks | GPLv3 | David Krentzlin | Kon Lovett | 0.3.6 |
| server-test | Utilities to help testing servers | BSD | Mario Domenech Goulart | 0.7 | |
| srfi-64 | SRFI 64: A Scheme API for test suites | SRFI | Sunjoong Lee | Diego A. Mundo | 1.0.7 |
| srfi-78 | SRFI-78: Lightweight testing | MIT | Sebastian Egner | Wolfgang Corcoran-Mathe | 0.6.0 |
| test | Yet Another Testing Utility | BSD | Alex Shinn | 1.3 | |
| test-utils | Test Utilities (for test egg) | BSD | Kon Lovett | 1.8.2 |
Cryptography
| Name | Description | License | Author | Maintainer | Version |
|---|---|---|---|---|---|
| chibi-crypto | Chibi Scheme's crypto library | BSD | Alex Shinn | Diego A. Mundo | 0.1.3 |
| hmac | HMAC provides a HMAC using the message-digest interface. | BSD | Thomas Hintz | Ivan Raikov | 7.3.0 |
| md2 | Message Digest 2 algorithm as defined in RFC1319 | BSD | Tobias Heilig | Ivan Raikov | 1.5 |
| md5 | Computes MD5 (RFC1321) checksums | Public Domain | Colin Plumb, packaged for Chicken by Peter Bex | Kon Lovett | 4.2.0 |
| message-digest | Message Digest (omnibus) | BSD | Kon Lovett | 4.4.0 | |
| message-digest-primitive | Message Digest Primitive | BSD | Kon Lovett | 4.4.0 | |
| message-digest-type | Message Digest Type | BSD | Kon Lovett | 4.4.4 | |
| message-digest-utils | Message Digest Support | BSD | Kon Lovett | 4.4.2 | |
| pbkdf2 | Password-Based Key Derivation Function as defined in RFC2898 | BSD | Tobias Heilig | Ivan Raikov | 1.4 |
| rabbit | Rabbit stream cipher. | Public Domain | Martin Boesgaard, Mette Vesterager, Thomas Christensen and Erik Zenner | Lilianna Smólska | 3.0 |
| ripemd | RIPE Message Digest | BSD | Kon Lovett | 2.2.0 | |
| sha1 | Computes SHA1 (FIPS-180-1) checksums | Public Domain | Steve Reid, packaged for Chicken by Peter Bex | Kon Lovett | 4.2.0 |
| sha2 | Computes 256-, 385- and 512-bit SHA2 checksums | BSD | Aaron D. Gifford and Daishi Kato | Kon Lovett | 4.3.0 |
| simple-md5 | Computes MD5 (RFC1321) checksums | Public Domain | Colin Plumb, packaged for Chicken by Peter Bex | Peter Bex | 0.2.1 |
| simple-sha1 | A fast and simple SHA1 implementation with minimal dependencies | Public Domain | Steve Reid and felix winkelmann | felix winkelmann | 1.3 |
| tiger-hash | Tiger/192 Message Digest | BSD | Kon Lovett | 4.2.0 | |
| totp | HMAC-Based and Time-Based One-Time Password algorithms as defined in RFC4226 and RFC6238 | BSD | Ivan Raikov | Ivan Raikov | 1.1 |
| uuid-lib | OSF DCE 1.1 UUID | BSD | Kon Lovett | 0.0.18 |
User interface toolkits
| Name | Description | License | Author | Maintainer | Version |
|---|---|---|---|---|---|
| bb | An easy-to-use GUI toolkit based on FLTK | BSD | felix winkelmann | 1.33 | |
| tkgui | A Scheme/TclTk GUI build tool | BSD-2 | J Altfas | v0.8.8.9 |
Code generation
| Name | Description | License | Author | Maintainer | Version |
|---|---|---|---|---|---|
| crunch | An embedded compiler for a statically typed subset of R7RS Scheme | BSD | felix winkelmann | 0.9993 | |
| crunch-simd | SIMD extensions for the CRUNCH compiler | BSD | felix winkelmann | 0.2 | |
| fp | An interpreter/translator for a dialect of John Backus' FP language | BSD | felix winkelmann | 0.9 |
Miscellaneous
| Name | Description | License | Author | Maintainer | Version |
|---|---|---|---|---|---|
| abbrev | Create unique abbreviations for a list of strings | LicenseRef-OWL-0.9.4 | Peter Lane, Lilianna Smólska | Lilianna Smólska | 1.0 |
| advice | 'advise' functionality | BSD | felix winkelmann | 0.5 | |
| apropos | CHICKEN apropos | BSD | Kon Lovett | 4.0.2 | |
| big-chicken | Wrapper module for all core modules | BSD | felix winkelmann | 1.3 | |
| bvconv | cffi bindings to iconv glibc. On bytevectors | BSD | Anton Idukov | 1.0.2 | |
| check-errors | Argument checks & errors | BSD | Kon Lovett | 4.0.1 | |
| chibi-app | Chibi Scheme's app library | BSD | Alex Shinn | Diego A. Mundo | 0.1.1 |
| chicken-blob | Replacement for CHICKEN 5's 'blob' module | BSD | Felix L. Winkelmann | 0.2 | |
| compile-file | Programmatic compiler invocation | BSD | The CHICKEN Team | 1.4 | |
| condition-utils | SRFI 12 Condition Utilities | BSD | Kon Lovett | 2.4.2 | |
| define-options | Conveniently bind to getopt-long options | LGPL | Idiomdrottning and Chris Brannon | 1.24 | |
| dynamic-import | Dynamic Import | Public Domain | Kon Lovett | 1.6.0 | |
| expand-full | Full macro expansion | BSD | Kon Lovett | 2.2.1 | |
| genann | Chicken bindings to genann - a simple neural network library in ANSI C | Zlib | Diego A. Mundo | 0.2.3 | |
| getopt-long | Command line option parsing. | LGPL-3 | Ivan Raikov | 4.1 | |
| getopt-utils | Utilities for getopt-long | BSD | Kon Lovett | 1.3.0 | |
| memoize | Procedures memoization | BSD | Arthur Maciel | Kon Lovett | 1.0.0 |
| memory-mapped-files | Memory-mapped file access for UNIX and Windows | BSD | The CHICKEN Team, Windows support by "rivo" | 0.6 | |
| nutils | An eclectic set of utilities | BSD-2 | J Altfas | 0.4.5.1 | |
| optimism | Command line option handling | Public Domain | Evan Hanson | 1.0.0 | |
| posix-regex | A thin wrapper around POSIX regular expression matching | GPL-3 | Sören Tempel | 0.1.3 | |
| posix-utils | posix-utils | BSD | Kon Lovett | 2.1.7 | |
| regex | Compatibility library for old regular expression API | BSD | felix winkelmann | The CHICKEN team | 2.1 |
| shell | Convenient shell-command invocation | public domain | Felix Winkelmann | 0.5 | |
| srfi-253 | SRFI 253: Data (Type-)Checking | MIT | Artyom Bologov | Jeremy Steward | 0.3.1 |
| srfi-29 | Localization | BSD | Scott G. Miller (for CHICKEN Kon Lovett) | Kon Lovett | 4.0.1 |
| srfi-34 | SRFI-34: Exception Handling for Programs | SRFI | Richard Kelsey, Michael Sperber | Ben Clark, Jörg F. Wittenberger | 0.8 |
| srfi-35 | SRFI-35 Conditions | MIT | Richard Kelsey and Michael Sperber | Sergey Goldgaber | 0.1 |
| srfi-37 | A simple and flexible command-line option parsing facility | SRFI | Anthony Carrico | 1.5 | |
| stalin | An aggressively optimizing Scheme->C compiler | GPL-2 | Jeffrey Mark Siskind, ported to CHICKEN by felix winkelmann | 0.11.12 | |
| svn-client | A wrapper around Subversion's libsvn_client C library. | Public Domain | Alejandro Forero Cuervo | Peter Bex | 1.4 |
| this | Python's "this" module ported to CHICKEN | BSD | Mario Domenech Goulart | 0.1 | |
| typed-records | Typed variants of various record-definition macros | BSD | felix winkelmann | megane | 0.84 |
Concurrency and parallelism
| Name | Description | License | Author | Maintainer | Version |
|---|---|---|---|---|---|
| deterministic-threads | disable timer-driven thread-scheduling globally | BSD | Felix Winkelmann | 0.1 | |
| futures | Concurrent evaluation of expressions | BSD | Felix Winkelman | Kon Lovett | 2.0.2 |
| mailbox | Thread-safe queues with timeout | BSD | felix winkelman and kon lovett | 3.3.10 | |
| srfi-18 | SRFI-18 thread library | BSD | The CHICKEN Team | The CHICKEN Team | 0.2.2 |
| synch | Synchronization Forms | BSD | Kon Lovett | 3.3.13 | |
| thread-utils | Thread Utilities | BSD | Kon Lovett | 2.3.0 | |
| timed-resource | Resource w/ Timeout | BSD | Kon Lovett | 2.4.5 |